Удаление из файла эксель ненужных страниц средствами 1С без COM и через COM

Публикация № 1186239

Разработка - Обмен данными 1С - Загрузка и выгрузка в Excel

Как средствами 1С из файла эксель удалить ненужные листы без COM и с ним. Я разрабатывал на платформе 1С:Предприятие 8.3 (8.3.14.1694)

1. Создать справочник, нам он понадобится, чтобы через предприятие управлять, какие страницы нам нужны, "СписокЛистовВФайлеЭксель" с реквизитами: 

"Используется" - булево

"Сохранить" - булево

"Удалить" - Удалить


Модуль менеджера справочника

&НаСервере
Процедура ДобавлениеЗаписи(Вх_Наименование) Экспорт 
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	СписокЛистовВФайлеЭксель.Ссылка КАК Ссылка
	|ИЗ
	|	Справочник._СписокЛистовВФайлеЭксель КАК СписокЛистовВФайлеЭксель
	|ГДЕ
	|	СписокЛистовВФайлеЭксель.Наименование ПОДОБНО &Наименование";
	
	Запрос.УстановитьПараметр("Наименование", Вх_Наименование);
	
	Результат = Запрос.Выполнить();
	
	Если Результат.Пустой() Тогда
		
		НовЭлемент = Справочники.СписокЛистовВФайлеЭксель.СоздатьЭлемент();
		НовЭлемент.УстановитьНовыйКод();
		НовЭлемент.Наименование = Вх_Наименование;
		
		Попытка
			НовЭлемент.Записать();
		Исключение
			ЗаписьЖурналаРегистрации("СписокЛистовВФайлеЭксельДляУдаления", УровеньЖурналаРегистрации.Ошибка,,, "Не удалось записать: " + Строка(ОписаниеОшибки())); 
		КонецПопытки;
		
	КонецЕсли; 
	
КонецПроцедуры // ДобавлениеЗаписи()



 

2. Любая обработка

&НаСервере
Функция УдалитьЛистыЭксель(АдресФайлаНаСервере, ИмяФайла, ДокРеализацияСсылка)
    
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла(ТипВыбранногоФайла); //"xlsx"
    ДанныеФайла = ПолучитьИзВременногоХранилища(АдресФайлаНаСервере);
    ДанныеФайла.Записать(ИмяВременногоФайла);
    
    СтраницаСправкаРасчетНайдена = Ложь;
    
    
    // средствами 1С
    Попытка
        // Выполняется долго на больших файлах.
        
        ТабличныйДокументЭксельВесь = Новый ТабличныйДокумент;
        ТабличныйДокументЭксельВесь.Прочитать(ИмяВременногоФайла, СпособЧтенияЗначенийТабличногоДокумента.Значение);    // СпособЧтенияЗначенийТабличногоДокумента - новый параметр платформы 8.3.6. Второе значение "Текст".
        
        
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
        |    СписокЛистовВФайлеЭксель.Ссылка КАК Ссылка,
        |    СписокЛистовВФайлеЭксель.Наименование КАК Наименование
        |ИЗ
        |    Справочник.СписокЛистовВФайлеЭксель КАК СписокЛистовВФайлеЭксель
        |ГДЕ
        |    СписокЛистовВФайлеЭксельДляУдаления.Используется = ИСТИНА
        |    И СписокЛистовВФайлеЭксельДляУдаления.Сохранить = ИСТИНА";
        
        Результат = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Наименование");
        
        // обходим области файла эксель
        Для Каждого ОбластьТД ИЗ ТабличныйДокументЭксельВесь.Области Цикл
            
            // запоминаем какие в файле эксель были страницы, чтобы потом в предприятии включить только нужные
            Справочники.СписокЛистовВФайлеЭксельДляУдаления.ДобавлениеЗаписи(ОбластьТД.Имя);
            
            // Обходим сраницы из спр, и смотрим их в файле, чтобы ее сохранить
            Для каждого СтрРезультат Из Результат Цикл
                Если ВРег(ОбластьТД.Имя) = ВРег(СтрРезультат) Тогда
                    
                    // вытащим нужный лист в Табличный документ и сохраним его
                    ТабличныйДокумент_СтраницаСчет = Новый ТабличныйДокумент;
                    ТабличныйДокумент_СтраницаСчет = ТабличныйДокументЭксельВесь.ПолучитьОбласть(ОбластьТД.Имя);
                    
                    ИмяВременногоФайлаНовый = ПолучитьИмяВременногоФайла(ТипВыбранногоФайла); //"xlsx"
                    ТабличныйДокумент_СтраницаСчет.Записать(ИмяВременногоФайлаНовый, ТипВыбранногоФайла); // Это наш новый файл только с нужной стриницей
                    
                    // для помещения во врем.хранилище для передачи на сервер
                    ДвоичДанные = Новый ДвоичныеДанные(ИмяВременногоФайлаНовый);
                    Адрес = ПоместитьВоВременноеХранилище(ДвоичДанные, Новый УникальныйИдентификатор);
                    
                    СтраницаСправкаРасчетНайдена = Истина;
                конецЕсли;
            КонецЦикла; 
        КонецЦикла;
        
        
    Исключение
        Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
        Адрес = АдресФайлаНаСервере;
    КонецПопытки;
    
    Если СтраницаСправкаРасчетНайдена = Ложь Тогда
        Сообщить("У файла " + ИмяФайла + "  не найдена страница Справка-расчет или не включена в справочнике СписокЛистовВФайлеЭксельДляУдаления", СтатусСообщения.Важное);
    КонецЕсли; 
    
    
    
    // через COM
    
    //ЛистЭксель = "СФ выд";
    //
    //ИмяВременногоФайла = ПолучитьИмяВременногоФайла(ТипВыбранногоФайла); //"xlsx"
    //ДанныеФайла = ПолучитьИзВременногоХранилища(АдресФайлаНаСервере);
    //ДанныеФайла.Записать(ИмяВременногоФайла);
    //
    //УдалосьУдалитьЛист = Истина;
    //
    //Попытка
    //    //ДокExcel = ПолучитьCOMОбъект("","Excel.Application");
    //    ExcelФайл = ДокExcel.WorkBooks.Open(ИмяВременногоФайла);
    //    
    //    Для Сч = 1 По ExcelФайл.Sheets.Count Цикл
    //        
    //        Если Сч > ExcelФайл.Sheets.Count Тогда
    //            Прервать;
    //        КонецЕсли; 
    //        
    //        ИмяЛиста = ExcelФайл.Sheets(Сч).Name;
    //        
    //        Запрос = Новый Запрос;
    //        Запрос.Текст = "ВЫБРАТЬ
    //                       |    СписокЛистовВФайлеЭксельДляУдаления.Ссылка КАК Ссылка,
    //                       |    СписокЛистовВФайлеЭксельДляУдаления.Наименование КАК Наименование
    //                       |ИЗ
    //                       |    Справочник.СписокЛистовВФайлеЭксельДляУдаления КАК СписокЛистовВФайлеЭксельДляУдаления
    //                       |ГДЕ
    //                       |    СписокЛистовВФайлеЭксельДляУдаления.Используется = ИСТИНА
    //                       |    И СписокЛистовВФайлеЭксельДляУдаления.Наименование = &Наименование";
    //        
    //        Запрос.УстановитьПараметр("Наименование", ИмяЛиста);
    //          
    //        Результат = Запрос.Выполнить();
    //        Если НЕ Результат.Пустой() Тогда
    //            ExcelФайл.Sheets(ИмяЛиста).Select();
    //            ExcelФайл.ActiveSheet.Delete();
    //            
    //            Сч = Сч - 1;
    //        КонецЕсли;     
    //    КонецЦикла;
    //    
    //    // начинаем закрывать файл
    //    ДокExcel.DisplayAlerts = 0;
    //    
    //    // сохраняем его в новый временный, для помещения во врем.хранилище на сервер
    //    ИмяВременногоФайлаНовый = ПолучитьИмяВременногоФайла(ТипВыбранногоФайла); //"xlsx"
    //    ExcelФайл.SaveAs(ИмяВременногоФайлаНовый);
    //    ExcelФайл.Close();
    //    
    //    
    //    ДокExcel.DisplayAlerts = 1;
    //    ДокExcel.Quit(); 
    //    ДокExcel = Неопределено;
    //    
    //    // для помещения во врем.хранилище для передачи на сервер
    //    ДвоичДанные = Новый ДвоичныеДанные(ИмяВременногоФайлаНовый);
    //    Адрес =  ПоместитьВоВременноеХранилище(ДвоичДанные, Новый УникальныйИдентификатор);
    //    
    //    
    //    СписокЛистов = ПолучитьСписокЛистов_EXCEL1C(ИмяВременногоФайлаНовый);
    //Исключение
    //    
    //    Сообщить("Ошибка. Возможно неверно указан номер листа книги Excel.    " + ОписаниеОшибки());
    //    
    //    СделатьЗаписьЖурналаРегистрации(УровеньЖурналаРегистрации.Предупреждение, "Не удалось удалить лист Excel.    " + ОписаниеОшибки());
    //    
    //    Адрес = АдресФайлаНаСервере;
    //    
    //    УдалосьУдалитьЛист = Ложь;
    //    
    //КонецПопытки;
    //
    //
    //Если УдалосьУдалитьЛист = Ложь Тогда
    //    ДокРеализацияОбъект = ДокРеализацияСсылка.ПолучитьОбъект();
    //    ДокРеализацияОбъект.Коментарий = ДокРеализацияОбъект.Коментарий + " Не удалось удалить лист Excel.";
    //    
    //    Попытка
    //        ДокРеализацияОбъект.Записать();
    //    Исключение
    //        Сообщить(ОписаниеОшибки());
    //    КонецПопытки; 
    //    
    //КонецЕсли; 
    
    
    Возврат Адрес; // Это наш новый файл только с нужной страницей в хранилище
    
КонецФункции

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. VmvLer 28.01.20 14:45 Сейчас в теме
Создать справочник чтобы на основе элементов этого справочника принимать решение удалить что-то в эксель или нет?

вы серьезно?
осмыслив эту идею и бегло пробежав код пришел к выводу, что
пропагандист подобных идей социально безответственный человек,
ибо такие идеи и код вредны для неокрепших умов.

да и неплохо бы сп читать и открывать для себя новое, например
метод ПакетОтображаемыхДокументов
который позволяет выполнить задачу без комов и тонн непонятного кода.
wolfsoft; Kolzah; ltfriend; +3 Ответить
2. pavel_pss 262 28.01.20 17:16 Сейчас в теме
(1) суть кода не в справочнике, это как пример запомнить какие страницы удалять из эксель!!!!!

И задача решается средствами 1С, а не через ком.

А метод "ПакетОтображаемыхДокументов" вообще не относится к решению текущей статьи. (Набор документов, которые нужно распечатать или сохранить в файл вместе.)

Поэтому за метод спасибо, но не нужно поливать грязью, то в чем не разобрались!!!

Я же показываю как из файла эксель с несколькими страницами удалить лишние страницы и оставить только нужные.
5. VmvLer 28.01.20 17:37 Сейчас в теме
(2) идея вредная, код ректальный - это мое объективное мнение .
А метод "ПакетОтображаемыхДокументов" может решить задачу из текущей статьи.

Если вы сможете найти решение этим методом, то ваша карма станет светлее.
3. MishaD 12 28.01.20 17:31 Сейчас в теме
Версию платформы укажите. Метод "Прочитать" файлы Эксель стал читать только с платформы 8.3.6, причем только первый лист. Возможность читать все листы появилась только в 8.3.10.
pavel_pss; +1 Ответить
4. pavel_pss 262 28.01.20 17:37 Сейчас в теме
6. bobank 181 28.01.20 18:41 Сейчас в теме
на счет нужности ненужных страниц спорно, а в остальном - хороший методический материал.
7. ltfriend 441 28.01.20 20:35 Сейчас в теме
Если в процедуре УдалитьЛистыЭксель при записи нового элемента произойдёт ошибка, то пользователь об этом не узнает, пока не посмотрит журнал регистрации.
8. pavel_pss 262 29.01.20 09:32 Сейчас в теме
(7) ну это сообщение уже на усмотрение программиста, просто подобный алгоритм может делаться ночью в фоне, поэтому запись только в журнал.
9. Pixar0000 06.02.20 00:18 Сейчас в теме
похоже на то, что "сидели с пацанами пили пиво" и тут генеральный "нагнул" - давно такого бреда не видел
10. Pixar0000 06.02.20 00:19 Сейчас в теме
говнокод в Исключении "запёр"
11. pavel_pss 262 07.02.20 12:31 Сейчас в теме
(10)прежде чем осуждать, напиши правильно и другие решат что говнокод а что нет! А сотрясать воздух все могут не подкрепляя!!!
12. pavel_pss 262 07.02.20 12:32 Сейчас в теме
(10)то то кроме комментов у тебя ничего нет!!! наверное боишься что твой доброкод сольют.
Оставьте свое сообщение

См. также

Обертка функций Excel на русском. Ускорение процесса разработки.

Статья Программист Нет файла v8 Windows Бесплатно (free) Загрузка и выгрузка в Excel Универсальные функции

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    4189    DmitryKotov    6       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Выгрузка из 1С номенклатуры со штрихкодами без программирования

Статья Программист Пользователь Стажер Нет файла v8 УТ11 Россия Бесплатно (free) Загрузка и выгрузка в Excel Внешние источники данных

Я так и не смог найти простой инструкции или обработки, чтобы выгрузить из 1С: Управление торговлей 11 номенклатуру вместе со штрихкодами, поэтому решил написать собственную инструкцию.

28.08.2019    5014    user1114182    4       

Загрузка картинок в справочники (Универсальная загрузка из табличного документа)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Обработка справочников Загрузка и выгрузка в Excel

Пример загрузки картинок в справочник Номенклатура (с помощью обработки универсальная загрузка данных из табличного документа). Проверялось на конфигурации УТ 11.4.7.

28.05.2019    4220    rasdag    2       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Преобразование EXCEL в таблицу значений без COM и других извращений

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    18122    9    Eret1k    43       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Копирование числовых ячеек из 1С в Excel

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    15506    itriot11    21       

Запись одной книги Excel на нескольких листах средствами 1С (без внешних компонент)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Пользователи часто просят сохранить им стопиццот отчетов в один файл Excel, чтобы отчеты были в одном файле. Ну или клиент хочет счет, накладную и счет-фактуру получить в одном документе. 1С умеет это делать без всяких там COM-объектов. Давайте разберемся, куда нажимать и что крутить.

14.01.2019    15715    starik-2005    25       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д)

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д). На примере загрузки в табличную часть документа Поступление товаров и услуг в УТ 11.4.

09.01.2019    9067    rasdag    14       

Работа с Excel через COM

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Несколько примеров работы с excel (ms office 2010, в моем случае) через COM.

01.10.2018    7177    jaroslav.h    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Выгрузка в Excel с использованием формата OpenXML, разбор файла sheet1.xml

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Судя по количеству просмотров темы https://infostart.ru/public/900022/ решил описать структуру файла Листа excel. На полноту не претендую, опишу то, что знаю.

21.09.2018    5472    user1045404    2       

Excel: создание в формате xlsx без COM технологии

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

По работе приходится часто выгружать данные в Excel формате. При большом количестве строк и формул этот процесс достаточно длительный. Решил написать для своих целей небольшую библиотечку для выгрузки данных. Используется технология open-xml. Никаких библиотек не надо, пишу напрямую в xml файлики. На данном этапе сделано форматирование, формулы.

10.09.2018    9179    user1045404    16       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Из Excel в 1С запросом

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    16437    m-rv    5       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Загрузка из Excel в управляемом приложении

Статья Программист Нет файла v8::УФ Windows Бесплатно (free) Загрузка и выгрузка в Excel

С появлением управляемого интерфейса стали актуальными вопросы в давно освоенных приемах работы. В частности, загрузка из файла.

30.11.2017    26773    alex_bitti    15       

Функция сохранения картинок из книги Excel в каталог с определением координат на листе

Статья Программист Нет файла v8 Бесплатно (free) Загрузка и выгрузка в Excel Универсальные функции

Разбор файла *.xlsx как Web-архива, выгрузка изображений без потери качества, с определением положения изображений.

12.11.2017    8611    user634820_zergemoth    1       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Работа с Excel

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    33214    arakelyan    39       

Невалидный XLSX при сохранении Табличного документа

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Ошибка открытия XLSX файлов, созданных при сохранении Табличного документа. (Невалидный формат файла)

21.10.2017    10721    saddy    3       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Почему при загрузке таблицы Excel в 1С возникают ошибки?

Статья Программист Нет файла v8 Бесплатно (free) Загрузка и выгрузка в Excel

При загрузке из EXCEL в 1С методом MS ADODB.Connection столкнулся с некоторыми проблемами, которые попытался устранить в ниже приведенной статье. Надеюсь, что статья поможет вам сократить время разработки.  Особая благодарность Андрею М. за публикацию //infostart.ru/public/163640/

28.04.2017    14086    dakork    4       

Загрузка значений свойств номенклатуры в Альфа-Авто с использованием обработки загрузки данных из табличного документа

Статья Программист Руководитель проекта Нет файла v8 1cv8.cf Автомобили, автосервисы Россия УУ Windows Учет ТМЦ Бесплатно (free) Загрузка и выгрузка в Excel

В публикации будет рассмотрено использование встроенной в отраслевую конфигурацию Альфа-Авто обработки по загрузке данных из табличного документа для заполнения значений дополнительных свойств номенклатуры.

13.10.2016    15741    miavolas    15       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Решение проблемы медленной загрузки из файла Excel, защищенного паролем

Статья Программист Нет файла v8 Россия Бесплатно (free) Загрузка и выгрузка в Excel

Столкнулся с проблемой загрузки из файла Excel. Загрузка занимала около получаса и не всегда заканчивалась успешно. Решение проблемы изложу в данной статье.

27.09.2016    9054    HAMMER_59    4       

Быстрая выгрузка больших плоских отчетов в Excel

Статья Программист Нет файла v8 Windows Бесплатно (free) Загрузка и выгрузка в Excel

Предлагаю способ для того, чтобы быстрее выгружать большие плоские отчеты из 1С 8 в Excel, без использования оперативной памяти на сервере и на клиенте, что очень важно, поскольку помогает избежать ошибок вида "Недостаточно памяти на клиенте" или "Недостаточно памяти на сервере". Не использует внешние компоненты. Минусы в том, что отчет выходит неформатированный, приходится настраивать ширину колонок, закрашивать границы, шрифты, жирность и т.п. Но когда отчет, выгружавшийся 3 часа, выгружается 20 минут, эти проблемы мои клиенты считают несущественными.

29.11.2015    14500    matveev.andrey.v    17       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    15309    etmarket    14